Disable deposits for ZIL
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 13, 2024 - 04:20 UTC
Investigating
Deposits are temporarily unavailable
Posted May 08, 2024 - 17:27 UTC
This incident affected: Cryptocurrencies (ZIL).