Disable withdrawals for SONO
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 16, 2024 - 09:00 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Dec 04, 2023 - 02:40 UTC
This incident affected: Cryptocurrencies (SONO).