Disable deposits for SUI
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 05, 2024 - 19:52 UTC
Investigating
Deposits are temporarily unavailable
Posted May 05, 2024 - 18:11 UTC
This incident affected: Cryptocurrencies (SUI).