Disable deposits for SUI
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 04, 2024 - 00:16 UTC
Investigating
Deposits are temporarily unavailable
Posted May 03, 2024 - 18:01 UTC
This incident affected: Cryptocurrencies (SUI).