Disable withdrawals for UAH (Visa/Mastercard GeoPay)
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 06, 2024 - 08:34 UTC
Investigating
Withdrawals are temporarily unavailable
Posted May 04, 2024 - 00:06 UTC
This incident affected: Fiat currencies (UAH (Visa/Mastercard GeoPay)).