Disable deposits for GMT
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 08:47 UTC
Investigating
Deposits are temporarily unavailable
Posted Apr 11, 2024 - 22:54 UTC
This incident affected: Cryptocurrencies (GMT).