Disable withdrawals for XRD
Incident Report for WhiteBIT
Update
We are continuing to investigate this issue.
Posted Sep 28, 2023 - 07:02 UTC
Investigating
Withdrawals closed due to Radix's upgrade from Olympia to Babylon
Posted Sep 27, 2023 - 21:48 UTC
This incident affects: Cryptocurrencies (XRD (RADIX)).