Disable withdrawals for KZT (Visa/Mastercard)
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 07:25 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 10, 2024 - 20:55 UTC
This incident affected: Fiat currencies (KZT (Visa/Mastercard)).