Disable deposits for NFP
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted May 03, 2024 - 11:50 UTC
Investigating
Deposits are temporarily unavailable
Posted Apr 04, 2024 - 17:12 UTC
This incident affected: Cryptocurrencies (NFP).