Disable withdrawals for LUNC
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 16:04 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 29, 2024 - 09:14 UTC
This incident affected: Cryptocurrencies (LUNC).