Disable deposits for FIL
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 11:10 UTC
Investigating
Deposits are temporarily unavailable
Posted Apr 11, 2024 - 10:39 UTC
This incident affected: Cryptocurrencies (FIL).