Disable deposits for ACE
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 02:12 UTC
Investigating
Deposits are temporarily unavailable
Posted Apr 12, 2024 - 22:58 UTC
This incident affected: Cryptocurrencies (ACE).