Disable withdrawals for GLMR
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 01:44 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 12, 2024 - 20:13 UTC
This incident affected: Cryptocurrencies (GLMR).