Disable withdrawals for GALA
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 07:07 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 21, 2024 - 22:21 UTC
This incident affected: Cryptocurrencies (GALA).