Disable deposits for C98
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 06:50 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 18, 2024 - 06:05 UTC
This incident affected: Cryptocurrencies (C98).