Disable withdrawals for JTO
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 07:28 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 13, 2024 - 08:44 UTC
This incident affected: Cryptocurrencies (JTO).