Disable withdrawals for TIA
Incident Report for WhiteBIT
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 14:09 UTC
Investigating
Withdrawals are temporarily unavailable
Posted Apr 30, 2024 - 13:08 UTC
This incident affected: Cryptocurrencies (TIA).